Mittwoch, 31. August 2011

Virus oder doch nicht?

Prolog:

Mahlzeit mitteinander,
ich schreibe jetzt in meiner Pause, euch, das soeben passiert.
Vor etwa 2 Stunden kam die nette Büronachbarin rüber und fragte uns ob wir ihr denn mit ihrem Laptop helfen könnten, da er scheinbar nicht mehr startet. Mein Chef entdeckte das große grinsen auf meinem Gesicht und schickte kurzerhand mich rüber.
Als ich ankam lief schon die Windows Starthilfe. Ich bin kein Fan von dieser und auch hätte ich noch nie erlebt das diese wirklich etwas bringt, also abstürzen lassen!
Beim Start sprang mir also die Frage ins Gesicht ob ich denn wieder in die Starthilfe will, ich glaube eher nicht. Im normalen Startmodus konnte ich einer Flagge beim wehen zuschauen. Nach kurzer Zeit erfuhr ich das diese auch nach etwa einer Stunde nicht verschwindet.
In meinem inneren Auge sah ich schon wieder die DISKPART.SYS vor mir.

Doch ich hatte "Glück". Im Abgesicherten Modus startete das Windows gewohnt und lies sich auch bediehnen. Ich brachte in Erfahrung das nichts neues Installiert wurde, das Problem jedoch gestern schon aufgetretten war.


Abgesichert?

Ich schaute zuerst etwas Ideenlos auf den Monitor bis mir einfiel dass die letzten SYS-Datein länger gebraucht haben und alle AVG im Namen hatte. Kam mir irgendwie bekannt vor. Handy gezückt und Google gefragt. Ah AVG-Antivierenprogramm. Ein Blick in Programme & Funktionen verriet mir das Antivier und AVG installiert sind.
Da ich freie Hand hatte und ich an einen Virus glaubte, mussten erst mal AVG & Antivier, dem Microsoft Security Essentials weichen. Soweit in der Theorie, die Praxis war eher ernüchternd. 
Als ich AVG deinstallierten wollte wurde der Rechner sehr langsam. Den Taskmanager in den Vordergrund gerufen, sorge für einen verwunderten Blick in meinem Gesicht. Keinerlei Auslastung! Auch unter Prozesse war nichts Aussergewöhnlich. Nachdem sich Minuten später dann doch der Resourcenmonitor geöffnet hatte, konnte ich auf den ersten Blick nichts seltsames entdecken. Auf den zweiten jedoch war zu erkennen dass die Festplatten Auslastung konstant bei 100% lag.
Der Versuch die Deinstallation  abzubrechen scheiterte kläglich, da der Laptop sich nun entschieden hatte erst mal gar nichts mehr zu tun.
Nach 10 Minuten der Warterei war die AVG.exe endlich aus dem Taskmanager verschwunden und ich deinstallierte Antivier. Dies war nach nur wenigen Minuten geschehen und ich konnte mich wieder AVG zuweden.



Die Sache mit dem Deinstallieren

Ein weiterer Versuch AVG zu deinstallieren zeigte mir, dass es wohl keinen Sinn haben wird, da die Festplattenauslastung sofort auf 100% Anstieg und sich nur mit viel Geduld und gutem zureden dazu bewegen lies, sich wieder normal einzupendeln. Das trotz der Auslastung fast nichts geschrieben und gelesen wird gibt mir immer noch zu denken.
Nach kurzer Rücksprache, ob es denn für die Besitzerin ok sei wenn ich etwas "dreckiges" probiere, löschte ich kurzerhand den AVG Ordner unter Programme.
Guter Dinge startete ich den Laptop neu und.... Lies die Flagge für 5 Minuten wehen, in der Hoffnung auf frische Luft und gute Gedanken.
Nachdem ich das Debugging aktiviert habe (hierzu nach dem BIOS "entf" drücken gefolgt von F8) startete ich erneut - NICHTS - also wieder in den Abgesicherten Modus und das Debugfile auslesen.
Dort war klar zu erkennen das CPU, Grafik und jede Menge anderer Treiber die nach zwei AVG.SYS Datein kamen, danke eines Fehlers nicht starteten.
Da ich freie Hand hatte und ich langsam in den Mittag wollte benannte ich kurzerhand die zwei SYS Dateien um und startete neu.
Man glaubt es nicht, danach funktionierte alles wieder!
Noch kurz "Aufgeräumt" und fertig war die Schose.

Greez
The Killer for Two